Investigating - Explorer is down
Jan 13, 12:54 UTC
Resolved - The issue was resolved. We have changed blockchain node that was used my Explorer
Jan 13, 16:29 UTC