Investigating - Explorer is 15 minutes behind
Apr 17, 11:34 UTC
Resolved - The issue was resolved. Some problem with mongo database.
Apr 17, 17:56 UTC